One or more field types are not installed properly. Go to the list settings page to delete these fields.

One or more field types are not installed properly. Go to the list settings page to delete these fields.

On my SharePoint 2013 on-premise environment.  I recently was backing up my content type hub site collection from my prod environment to my dev environment.  At the same time, I restored my managed metadata service Term Store to my dev environment from my prod environment.

Once completed, anytime I would try to navigate to the Term Store from my site collections, I would get this message:

Sorry, something went wrong
One or more field types are not installed properly. Go to the list settings page to delete these fields.

2014-11-13_10-56-47.png 

I tried to ensure that all the correct permissions were set in the Term Store/MMS but to no avail.

Looking in the ULS logs gave me this message:

Application error when access /_layouts/15/termstoremanager.aspx, Error=One or more field types are not installed properly. Go to the list settings page to delete these fields.   at Microsoft.SharePoint.Library.SPRequestInternalClass.GetListItemDataWithCallback2(IListItemSqlClient pSqlClient, String bstrUrl, String bstrListName, String bstrViewName, String bstrViewXml, SAFEARRAYFLAGS fSafeArrayFlags, ……

Some blog references indicated to disable and enable the SharePoint Publishing Infrastructure which I did that didn’t work as well.

I finally started looking individually at my Site Columns in the site collections and found some Site Columns of Managed Metadata type were not hooked up correctly to the correct Term Set in the Term Store or were orphan in that I did not really need them anymore.

Once I reset them pointing to the right Term Set or deleted them, I stopped getting this error.

Leave a Reply

Your email address will not be published. Required fields are marked *